Delayed evaluation of RUM and Logs monitors and issues affecting RUM data collection

Incident Report for Datadog US3

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 17:36 EDT

Monitoring

We've implemented a fix and logs and RUM monitors are now being evaluated. We're continuing to monitor the results.
Posted Jul 20, 2026 - 17:19 EDT

Update

Logs monitors are now being evaluated. We are continuing to investigate the issue with RUM data collection.
Posted Jul 20, 2026 - 16:58 EDT

Identified

We are currently investigating an issue affecting browser-based data collection (Real User Monitoring and Browser Logs) for some customers in the US3 region.

Customers may experience:
- Intermittent connection failures when the browser SDK sends RUM, Browser Logs, or CSP report data
- A small portion of browser telemetry not being delivered during the affected window
- Delayed monitor evaluations that rely on Logs, RUM, and Browser Logs

Our engineering teams have identified the cause and mitigation is in progress. Impact is limited to a subset of traffic in a single US3 availability zone, and systems are recovering.

We will provide further updates as the situation progresses.
Posted Jul 20, 2026 - 16:50 EDT
This incident affected: Log Management and RUM.