Delayed Logs

Incident Report for Datadog US3

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 13:19 EDT

Monitoring

We have deployed a fix and we are monitoring the results.
We will provide another update once the issue is fully resolved.
Posted Mar 17, 2026 - 13:11 EDT

Identified

We have identified the underlying issue and are working on a fix.
It is important to note that no data has been lost, and it will be backfilled and available once the service is operational again.
Posted Mar 17, 2026 - 13:01 EDT

Investigating

We are investigating increased latency processing Logs.
As a result of this issue, some users may may see delays or gaps for data in their logs queries.

To prevent false monitor alerts due to delayed data, monitors affected by the delay will not notify and will automatically resume once current data is available. All other monitors will operate normally.
Posted Mar 17, 2026 - 12:44 EDT
This incident affected: Log Management.