Elevated Error Rates for Monitors

Incident Report for Datadog US3

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 08:19 EDT

Monitoring

A fix has been implemented and we are monitoring the situation.
Posted Apr 29, 2026 - 08:11 EDT

Identified

We have identified the underlying issue and are working on a fix.
It is important to note that no data has been lost and it will be available once the service is fully operational.
Posted Apr 29, 2026 - 07:57 EDT

Investigating

We are investigating increased latency processing Service Check and Cloud Network Monitoring.
As a result of this issue, some users may see gaps or delays or partial query results on these monitors
Posted Apr 29, 2026 - 07:50 EDT
This incident affected: Cloud Network Monitoring and Monitors.