Delays in Logs and RUM monitors

Incident Report for Datadog US3

Resolved

Logs and RUM monitors are functioning as expected.
Posted Dec 17, 2025 - 10:50 EST

Monitoring

Log monitors have begun recovering as of 1525 UTC. We are actively monitoring the recovery.
Posted Dec 17, 2025 - 10:38 EST

Update

RUM monitors have recovered in US3. We are still actively investigating delays in Logs monitor evaluations.
Posted Dec 17, 2025 - 10:08 EST

Update

We are continuing to investigate this issue.
Posted Dec 17, 2025 - 09:23 EST

Investigating

We are currently investigating delays in evaluating monitors on Logs, RUM, and Dataset monitors. This started at 1301 UTC
Posted Dec 17, 2025 - 09:14 EST
This incident affected: Monitors.