Delayed Monitors Notifications

Incident Report for Datadog US3

Resolved

Delays are now resolved.
Posted Aug 28, 2025 - 05:01 EDT

Monitoring

We're seeing recoveries on our systems and are currently monitoring the situation.
Posted Aug 28, 2025 - 04:53 EDT

Investigating

We are investigating delays in Monitors Notifications, which began at 8:20 UTC.
Posted Aug 28, 2025 - 04:45 EDT
This incident affected: Monitors.